Sezione dedicata alle GUIDE e come fare ( Howto ) e gestire un decoder Enigma2 per utenti Avanzati - Approfondimenti e procedure più complesse.
  • Avatar utente
  • Avatar utente
Dopo aver reinstallato Linux (KDE Neon) sul Pc ho problemi con Samba. In sintesi: il decoder vede la rete, e settando da PC samba-usershare vede la cartella che io voglio, ma non la vede con la configurazione "normale" di samba (che aveva sempre funzionato).
la cosa che mi fa impazzire è che samba-usershare e samba "normale" (mountpoints sul decoder) puntano esattamente sulla stessa cartella del PC, cioè /samba.
Io ho anche modificato fstab da PC mettendogli una configurazione che una volta funzionava, cioè:
Codice: Seleziona tutto
rootfs			/		auto		defaults				1  1
proc			/proc		proc		defaults				0  0
devpts			/dev/pts	devpts		mode=0620,gid=5				0  0
usbdevfs		/proc/bus/usb	usbdevfs	noauto					0  0
tmpfs			/var/volatile	tmpfs		defaults				0  0
192.168.1.150/samba	/media/hdd	cifs	user=[user],pass=[miapsw],_netdev,rw,nolock,noauto,tcp	0 0
Dove sbaglio?
Nemoxyz ha scritto: 3 mesi @dsdoctorsubtilis hai controllato il file conf di samba sul decoder ?
Fugacemente. Ma io non li ho mai modificati. Comunque
smb-shares.conf è così
Codice: Seleziona tutto
[Root]
        comment = Everything - take care!
        path = /
        guest ok = yes
        read only = no
        valid users = root
        admin users = root
        force create mode = 600
        force directory mode = 700
        wide links = yes
        follow symlinks = yes

[Harddisk]
        comment = The harddisk
        path = /media/hdd
        guest ok = Yes
        read only = No
        valid users = root kids
        admin users = root
        force create mode = 0600
        force directory mode = 0700
        wide links = yes
        follow symlinks = yes
e smb-global.conf
Codice: Seleziona tutto
[global]
	workgroup = WORKGROUP
        security = USER
        map to guest = Bad User
        min receivefile size = 16384
        use sendfile = Yes
        aio read size = 16384
        aio write behind = true
        aio write size = 16384
        smb passwd file = /etc/samba/private/smbpasswd
        passdb backend = smbpasswd
        idmap config * : backend = tdb
        obey pam restrictions = Yes
        max stat cache size = 64
        unix password sync = Yes
        pam password change = Yes
        server multi channel support = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

        # Disable printer support for now
        disable spoolss = Yes
        load printers = No
        printcap name = /dev/null

        unix extensions = No
        allow insecure wide links = Yes

        oplocks = yes
        kernel oplocks = yes

        include = /etc/samba/distro/smb-branding.conf
        include = /etc/samba/distro/smb-shares.conf
        include = /etc/samba/distro/smb-vmc.conf

        include = /etc/samba/smb-user.conf
Nemoxyz ha scritto: 3 mesi eh ok allora modificali a tuo servizio credo sia lì il punto della questione ;-)
eh, ma prima che reinstallassi KDE Neon tutto funzionava senza che li avessi mai modificati.
In ogni caso: come li dovrei modificare? Voglio dire: che cosa dovrei modificare?
Domanda su liste canali

@Lionar salve buonasera , lista canali per ferg[…]

@Jack3000 mi fa piacere che lo abbia accettato.[…]

grazie mille :P

Backup 150

grazie mille :P